$re = '/^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d]{8,}$/m';
$str = 'BHV9CD8J';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);