package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.]{2,}|[^.]{2,3}\.[^.]{2})$`)
var str = `www.site.co.uk
subdomain.site.com
site.travel`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}