$re = '/^\d{1,3}(?:\.\d{3})*(?:,\d+)?$/m';
$str = '1
15
0,12
123.621
2.005.002220';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);