import re
regex = re.compile(r"([0-9]+\s+ok\s+[0-9]+\s+nok).*?(ltelidt|eiflmrj5)")
test_str = ("605sd25 schklog_1FS 13 ok 1 nok 106m 24_R23F eiflmrj5 d1us41 fd1d tm1500 o1t2enb1010 2m 2016-02-18 23:30:34 2016-02-19 07:14:01\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)