re = /(["'])(?:(?=(\\?))\2.)*?\1/m
str = '"tttt"+"zzzz"
"+"
\'aaaa\'+\'cccc\'
"\'+\'"
""+""+""
1+1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end