package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\s\S]*?\/)(\w+\.c)`)
var str = `a/b/c/d/file1.c
a/b/c/d/e/f/g/h/1/2/3/4/5/foo.c
dir1/dir2/newlinedir
/nextlinedir/bar.c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}