using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(?<href>.*?)""|src=""(?<imgsrc>.*?)""";
string input = @"<a rel=""nofollow"" href=""http://www.amazon.de/gp/product/B004DI7A5S/ref=as_li_tl?ie=UTF8&camp=1638&creative=6742&creativeASIN=B004DI7A5S&linkCode=as2&tag=webbigode-21"">PFIFF Reitstrumpf kariert, grau/lila, 37-39, 100322-144-37</a><img src=""http://ir-de.amazon-adsystem.com/e/ir?t=webbigode-21&l=as2&o=3&a=B004DI7A5S"" width=""1"" height=""1"" border=""0"" alt="" style=""border:none !important; margin:0px !important;"" />
<a rel=""nofollow"" href=""http://www.amazon.de/gp/product/B004DI7A5S/ref=as_li_tl?ie=UTF8&camp=1638&creative=6742&creativeASIN=B004DI7A5S&linkCode=as2&tag=webbigode-21""><img border=""0"" src=""http://ws-eu.amazon-adsystem.com/widgets/q?_encoding=UTF8&ASIN=B004DI7A5S&Format=_SL110_&ID=AsinImage&MarketPlace=DE&ServiceVersion=20070822&WS=1&tag=webbigode-21"" ></a><img src=""http://ir-de.amazon-adsystem.com/e/ir?t=webbigode-21&l=as2&o=3&a=B004DI7A5S"" width=""1"" height=""1"" border=""0"" alt="" style=""border:none !important; margin:0px !important;"" />
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}