re = /(?<!=[ ])(?<![=&|%])(\+|-)(?!\1|[ =])/m
str = 'a - b + c
a-b+c
a-=2
a=-2
a&-b
a|-2
a%-b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end