$re = '/[^"\s]++((?=\s*"[^\s])|(?=\s*$)|(?=[^"]+\s+"))/';
$str = 'test "hello world!" test2test1 test "hello world!" test2test1 test "hello world!" test2test1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);