import re
regex = re.compile(r"(?:\spublic\s+enum\s+DynamicVocabularyName\s*\{|\G,)\s+([A-Z_]+)(?=[^{}]*\})")
test_str = ("package com.motorolasolutions.vip.datatypes.names;\n\n"
"public enum DynamicVocabularyName {\n"
" ACTIVE_CRIMES_COUNT,\n"
" ACTIVE_CRIME_TYPE,\n"
" APPLICATION_NAME,\n"
" ARREST_COUNT,\n"
" AREA_DESCRIPTION,\n"
" AREA_NAME,\n"
" BAD_PARAMETER_NAME,\n"
" BATTERY_PERCENT,\n"
" CAROWNER_PERSON_ADDRESS,\n"
" CAROWNER_PERSON_FULLNAME,\n"
" CAROWNER_PERSON_PHONE,\n"
" CRIME_DATE_DESCRIPTION,\n"
" CRIME_SUBTYPE\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")