$re = '/^(\d{2}-\d{2}-\d{4})\s?(\d{2}:\d{2})\s?:([^:]+):\s?((?:(?!^\d{2}-\d{2}-\d{4}\s?\d{2}:\d{2}).)*)/sm';
$str = '14-08-2015 14:18 : Example : Hello =) How are you?
What are you 2 doing on the 14-08-2015 14:19
14-08-2015 14:19: Example2 : I\'m fine thanks!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);