const regex = /(?sm)^(\d{2}-\d{2}-\d{4})\s?(\d{2}:\d{2})\s?:([^:]+):\s?((?:(?!^\d{2}-\d{2}-\d{4}\s?\d{2}:\d{2}).)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)^(\\d{2}-\\d{2}-\\d{4})\\s?(\\d{2}:\\d{2})\\s?:([^:]+):\\s?((?:(?!^\\d{2}-\\d{2}-\\d{4}\\s?\\d{2}:\\d{2}).)*)', 'g')
const str = `14-08-2015 14:18 : Example : Hello =) How are you?
What are you 2 doing on the 14-08-2015 14:19
14-08-2015 14:19: Example2 : I'm fine thanks!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}