import re
regex = re.compile(r"(\d+)(\d\d)|(\d+).(\d+)", flags=re.MULTILINE)
test_str = ("115\n"
"1x15\n"
"01x15\n"
"S01E05\n"
"S1E5\n"
"S1E05\n"
"S0105")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")