re = /<[^>]*>([^<]+)</m
str = '<>hello<!><>Soumik<!><>Having a wonderful day?<!>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end