import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?<filter>PFE_FW_SYSLOG_ETH.*:)\\sFW:\\s(?<src_interface>[^ ]+)\\s+(?<action>\\w+).*(?<transport>tcp|udp|icmp)\\s(?<src>(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})|(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}$)\\s";
final String string = "Aug 2 09:16:37 10.10.10.10 Aug 2 09:16:37 externals-cl fpc1 PFE_FW_SYSLOG_ETH_IP: FW: xe-1/0/0.0 D 0800 34:62:5a:74:8f:c3 -> 64:b2:9a:7e:1b:4a tcp 184.154.189.91 10.1.1.1 41860 465 (1 packets)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}