$re = '/^(?=.*(orange|apple))(?!.*box).*$/m';
$str = 'One orange and one apple
One apple
One orange
orange and apple within a box
One apple and box
One orange and box
This contains none of accepted words so it doesn\'t match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);