$re = '/([a-z])([0-9])/m';
$str = 'Washington3|Final|Philadelphia1|Washington7|Final (10)|Philadelphia6|Houston5|Final|Detroit4|LA Dodgers1|Final|Cincinnati3|Oakland3|Final|Baltimore2|Cleveland2|Final|Tampa Bay0|Toronto2|Final|Boston7|Miami5|Final|NY Mets3|Milwaukee0|Final|Chi Cubs3|NY Yankees5|Final|Minnesota10|Chi White Sox3|Final|Kansas City6|Pittsburgh5|Final|St. Louis11|Arizona6|Final|Colorado3|Texas0|Final|LA Angels1|San Diego2|Final|Seattle1|Atlanta4|Final|San Francisco1';
$subst = "$1|$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;