re = /(?:[+-]?\d+(?:\.\d+)?[a-z]\^2 [+-] )?\d+(?:\.\d+)?[a-z] [+-] \d+(?:\.\d+)? = 0/m
str = '-3x^2 + 4.8x + 4.0 = 0
5x + 4 = 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end