package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(COUNT=[^;]*;)?$`)
var str = `The count is: COUNT=1;
The count is: `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}