#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<error>ORA-\d+)"
Local $sString = "tman.oci.exe.42636 (trace:0) (DbDmlStmtHandle::Execute): Error[343] -> Database access error (-1)." & @CRLF & _
"Msg: [" & @CRLF & _
"ORA-00001: unique constraint (UCICOBG.IXCTPROFILEUNIQUEID) violated" & @CRLF & _
"]" & @CRLF & _
".13808 (trace:0) (DBReopenDatabase(connection lost)): Error[343] -> Database access error (-3113)." & @CRLF & _
"Msg: [" & @CRLF & _
"ORA-03113: end-of-file on communication channel" & @CRLF & _
"Process ID: 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")