#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^(?<group>" & @CRLF & _
" (?<value>[^()\r\n]+)*" & @CRLF & _
" \((?<groupVal>(?&group)|(?&value))\)" & @CRLF & _
" (?&groupVal)*" & @CRLF & _
")$"
Local $sString = "(F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))" & @CRLF & _
"(F(i(r(s)t))) ((S)(e)((c)(o))n)d (((((((Third)))))))" & @CRLF & _
"((F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")