re = /^(([^()\r\n]+)*\(((?1)|(?2))\)(?3)*)$/m
str = '(F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))
(F(i(r(s)t))) ((S)(e)((c)(o))n)d (((((((Third)))))))
((F(i(r(s)t))) ((S)(e)((c)(o))n)d) (((((((Third)))))))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end