re = /(?:[MF]D(?:(?![MF]D).){4,6}){3,10}/m
str = 'MNRYLNRQRLYNMYRNKYRGVMEPMSRMTMDFQGRYMDSQGRMVDPRYYDHYGRMHDYDRYYGRSMFNQGHSMDSQRYGGWMDNPERYMDMSGYQMDMQGRWMDAQGRYNNPFSQMWHSRQGH
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end