$re = '/^[\w\-\p{Thai}]+$/m';
$str = 'testaa1-_as32เชื่อว่าต้องมีหลายคนที่ไม่ค่อยได้';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);