package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Mon(?:.?|day)?)(?:[\.,])?$`)
var str = `Monday.
Mon
Mon,
Mon.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}