# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[-]?(?:[0-9]*[.])?[0-9]+(?:e[-]?[0-9]+)?$"
test_str = ("0\n"
"1\n"
"-0\n"
"-1\n"
"+0\n"
"+1\n"
"01\n"
"-01\n"
"+01\n\n"
"2.3\n"
"-2.3\n"
"1.00\n"
"0.00\n"
"-0.00\n"
"00.00\n"
"-00.00\n"
"02.3\n"
".0\n"
".1\n"
"-.1\n"
"0.\n"
"1.\n"
"10.\n"
"2,3\n"
",0\n\n"
"0e0\n"
"2e5\n"
"2.3e5\n"
"-2.3e5\n"
"2.3e-5\n"
"2.3e03\n"
"2.3e0\n"
"0.01e4\n"
".1e5\n"
"-.1e5\n"
"-.0e0\n"
"-0.0e10\n"
"2,3e5\n"
" \n"
".\n"
"-\n"
"-.\n"
"b1\n"
"1b\n"
"2-3\n"
"3.4.5\n"
"4.,6\n"
"1,.\n"
"e\n"
"-e\n"
"-.e\n"
".e4\n"
"1e2-2\n"
"e2.3\n"
"e2.3.4\n"
"-e10\n"
"1e.-\n"
"10e.\n"
"1\\n\n"
"1\\t\n"
"1 1\n"
"\\n\n"
"\\t\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.