re = /=3D(https[^\\]+)/
str = 'https://www.google.com/url?rct=3Dj\\u0026sa=3Dt\\u0026url=3Dhttps://rivesjournal.com/inside-track-trading-focus-on-shares-of-adobe-systems-inc-adbe/48453/\\u0026ct=3Dga\\u0026cd=3DCAEYASoTOT'
# Print the match result
str.match(re) do |match|
puts match.to_s
end