$re = '`sync pair :(?P<syncpair>[a-zA-Z0-9_-]{30,36})`m';
$str = '2022-12-21T11:48:00,001 [schedulerFactor_Worker-4, , ] INFO  [,,] [userAgent=] [system=,component=,object=] [,] [] c.s.f.s.scheduler.SchedulerTask - sync process started on  2022-12-21T06:48:00.000780  for sync pair :17743b1b-a067-4478-a6d8-7b1cff04175 for JobId :dc8dc0dd-fdb9-4873-af55-1c70ba2047a5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);