$re = '`(?:<!\[CDATA\[(?<cdata>.*?)\]\]>|(?<xml><\?.*?\?>)|<!--(?<comment>.*?)-->|<\s*(?<tag>[A-z][A-z0-9-_.:]*)(?:\s+(?:[A-z][A-z0-9-_.:]*)\s*(?:=\s*(?<quote>["\'])((?:\\\\\k<quote>|(?:(?!\k<quote>)).)*)(\k<quote>)\s*)?)*\s*(?:/\s*>|>(?<innerHTML>.*)?<\s*/\s*\k<tag>\s*>)|(?<text>[^<]*))`ms';
$str = '<?xml version=\'1.0\' encoding=\'shift_jis\'?>
<!-- foo -->
<foo>bar</foo>
Baz
<foo asdf="foo" />
<CharacterInfo defaultUid=\'\'>
<Character
name=\'??????\'
uid=\'511111\'
weapon=\'??\'
HR=\'7\' GR=\'0\' lastLogin=\'1645561498\'
sex=\'M\' />
<Character name =\'Potatoe/>sss\' uid= \'511111\' weapon = \'??\' HR=\'7\' GR="0" lastLogin=\'1645561498\' sex=\'M\' />
</CharacterInfo>
Plain text
<hr/>
Multi
line
text
<br />
<!--
This is a comment!
<foo />
-->
<foo
bar/>
<baz asdf="2"></baz>
<asd foo="asd\\"q\'we" / >
<b>Hello, <i>World</i>!</b>
<Character
name=\'??????\'
uid=\'511111\'
weapon=\'??\'
HR=\'7\' GR=\'0\' lastLogin=\'1645561498\'
sex=\'M\' />
<Character name =\'Potatoe/>sss\' uid= \'511111\' weapon = \'??\' HR=\'7\' GR="0" lastLogin=\'1645561498\' sex=\'M\' />
<![CDATA[]]>
<![CDATA[Foobar<>]]>
<![CDATA[
asdasdasd
adsd
sd
sd
]]>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);