$re = '/ex_date\(\s*[a-z0-9]+#[a-z0-9]+\s*\)/m';
$str = 'ex_date( ds23d#d4ff5 , we# )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);