package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http[^ \n]*`)
var str = `Adf adf asdf asdf asfdf https://.com/abcabcabc kdfja ladsjfladsjf ladksjf ladsjfl adsfadf adf asdf asdf asfdf https://.com/abcabcabc\n kdfja ladsjfladsjf ladksjf ladsjfl adsf https://.com/djflkajdsfl\n\n djldjfld djfladjf ldfdjlkfj ldfj.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}