re = /(?s)(?<=<code>).*?(?=<\/code>)/
str = 'Loreum Ipsum Dolor Sit Amet <code>Some HTML Code like <h1>Head</h1></code>. Loreum Ipsum <code>Some Code</code> Dolor Sit Amet.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end