package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\W`)
var str = `g 1_2A2@33%4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}