import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\\<\\!--begin(?<type>\\w+)--\\>)(?<embed>.+)(?>\\<\\!--end(?>\\1)--\\>)";
final String string = "<p><!--beginTweet--></p><blockquote class=\"twitter-tweet\"><p dir=\"ltr\" lang=\"en\">The <a href=\"https://twitter.com/hashtag/SeaKraken?src=hash&ref_src=twsrc%5Etfw\">#SeaKraken</a> & <a href=\"https://twitter.com/ClimateArena?ref_src=twsrc%5Etfw\">@ClimateArena</a> will require all guests, ages 12+, attending Kraken games, concerts & events at Climate Pledge Arena to provide proof of vaccination to keep fans, staff, players & artists safe.<br><br>More info → <a href=\"https://t.co/f2EmV5cXd0\">https://t.co/f2EmV5cXd0</a> <a href=\"https://t.co/wJY9ElJ0DQ\">pic.twitter.com/wJY9ElJ0DQ</a></p>— Seattle Kraken (@SeattleKraken) <a href=\"https://twitter.com/SeattleKraken/status/1435273531256885255?ref_src=twsrc%5Etfw\">September 7, 2021</a></blockquote><p><!--endTweet--></p>\n"
+ "<!--beginFart-->df<!--endFart-->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}