$re = '/^(?!BOLO)/m';
$str = 'BOLO
BOLO CHOCOLATE
CHOCOLATE
RECEITAS BOLO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);