re = /(?:(?:[A-Z][\w'-]*|and) +)+(?=[sS]ales?)/
str = ';;;;;PRINCIPAL CUSTOMERS In fiscal 2005, the Company derived approximately 21% ($4,782,852) of its consolidated revenues from continuing operations from direct transactions with Kmart Corporation. Sales of Computer products was good. However, Computer\'s Parts and Display Segment sale has been decreasing.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end