#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+(?=\R\p{L}+$)"
Local $sString = "County Road 99 " & @CRLF & _
"Sauk Centre, Minnesota 56378" & @CRLF & _
"USA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")