# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({\"response\":{\"result\":\[)(({\"clientId\":\"(\d{1,})\")?,?(\"clientName\":\"(\w{1,})\")?,?(\"projectName\":\"(\w{1,})\")?,?(\"projectId\":\"(\d{1,})\")?,?(\"jobName\":\"(\w{1,})\")?,?(\"jobStatus\":\"([\w-]{1,})\")?,?(\"hours\":\"([:\d]{1,})\")?,?(\"assignedBy\":\"([\w.]{1,})\")?,?(\"description\":\"([\w]{0,})\")?,?(\"isActive\":\"(true|false{0,})\")?,?(\"fromDate\":\"([\d-]{0,})\")?,?(\"jobId\":\"([\d]{0,})\")?,?(\"totalhours\":\"([\w]{0,})\")?,?(\"ratePerHour\":([\d]{1,}))?,?(\"compsize\":([\d]{1,}))?,?(\"jobcolor\":([\d]{1,}))?,?(\"projectManager\":({\"erecno\":\"([\d]{1,})\"}))?,?(\"deleteAllowed\":(true|false)}))(],\"message\":\"Data fetched successfully\",\"uri\":\"\/api\/timetracker\/getjobs\",\"status\":0}})"
test_str = "{\"response\":{\"result\":[{\"clientId\":\"17096000000079988\",\"clientName\":\"Nuriosan\",\"projectName\":\"Minecraft\",\"projectId\":\"17096000000090003\",\"jobName\":\"PICKAR\",\"jobStatus\":\"In-Progress\",\"hours\":\"00:00\",\"assignedBy\":\"hieu.siah\",\"isActive\":\"true\",\"fromDate\":\"2019-10-11\",\"jobId\":\"17096000000090015\",\"totalhours\":\"\",\"ratePerHour\":0,\"compsize\":0,\"jobcolor\":1,\"projectManager\":{\"erecno\":\"17096000000077005\"},\"deleteAllowed\":false}],\"message\":\"Data fetched successfully\",\"uri\":\"/api/timetracker/getjobs\",\"status\":0}}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.