$re = '/(?:(?!\s{5}).)+/m';
$str = 'aaa aaa aaa aaaa aaaaa aaaaa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);