$re = '/(?:\d{1,3}.){3,4}(?:\d{1,5})/mi';
$str = '123.123.123.123
123123123123123 <-- error123123123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);