#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/)?(?:www\.)?youtu(?:\.be\/|be.com\/\S*(?:watch|embed)(?:(?:(?=\/[-a-zA-Z0-9_]{11,}(?!\S))\/)|(?:\S*v=|v\/)))([-a-zA-Z0-9_]{11,})"
Local $sString = "youtu.be/iwGFalTRHDA" & @CRLF & _
"youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch?v=MoBL33GT9S8&feature=share" & @CRLF & _
"https://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/watch?v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/embed/v=iwGFalTRHDA" & @CRLF & _
"https://www.youtube.com/watch/iwGFalTRHDA" & @CRLF & _
"http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share" & @CRLF & _
"" & @CRLF & _
"// will not match" & @CRLF & _
"https://www.youtube.com/feed/subscriptions" & @CRLF & _
"https://www.youtube.com/channel/UCgc00bfF_PvO_2AvqJZHXFg" & @CRLF & _
"https://www.youtube.com/c/NatGeoEdOrg/videos" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")