import re
regex = re.compile(r"\b\S*[AĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴAĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴAĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴAĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴAĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴAĂÂÁẮẤÀẰẦẢẲẨÃẴẪẠẶẬĐEÊÉẾÈỀẺỂẼỄẸỆIÍÌỈĨỊOÔƠÓỐỚÒỒỜỎỔỞÕỖỠỌỘỢUƯÚỨÙỪỦỬŨỮỤỰYÝỲỶỸỴA-Z]+\S*\b", flags=re.MULTILINE)
test_str = ("here are three distinct writing systems that have played a part throughout Vietnamese history. The first written form of Vietnamese is called Chöõ Nho, and is based off of the Chinese script (Janse, 1997). This form of writing was implemented by most, if not all of the government writing, official transactions, taught in schools and used in literature directly after the Chinese rule (Janse, 1997). Đà\n"
"The second dominate writing system is called Chöõ Noâm; witch translates close to vulgar or demotic (Janse, 1997). The writers of Vietnam decided that they wanted their own dialect in witch to write sown their history and customs, rather than using the Chinese dialect being in use for so long (Janse, 1997). Nguyeãn-Thuyeân, also written Haøn Thuyeân, was a poet in the 13th century, and is often deemed the person responsible to the spreading of this script (Janse, 1997). Too create this form two Chinese characters were usually combined into one (Janse, 1997). The first indicated the meaning of the Vietnamese word, and the second the pronunciation of the word (Janse, 1997).\n"
"The third and final form of writing is called Chöõ Quoác Ngöõ; translated national language (Janse, 1997). This form was brought about by catholic mercenaries who wished to translate payer books to a romanticized script around the 17th\n"
"Open Full Document\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")