$re = '/.+?possible/';
$str = 'The greedy modifier, ?, in regex will change the behavior of the preceeding quantifier to match as few characters as possible instead of as many as possible.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);