re = /[^ -+--~]/m
str = '~`!@#$%^&*()-=_+~<>?"":|}{[]\\\';//.,abcdefghijklmnopqrstuvwxyz09123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end