$re = '/^(?!.*opt3).*(filename\.txt)/m';
$str = 'filename.txt opt1 opt2 opt4
filename.txt opt1 opt2 opt3 opt4
filename.txt opt1 opt2 opt4
filename.txt opt1 opt2 opt3 opt4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);