import re
regex = re.compile(r"\|MessageTranID\=(?<MessageTranID>[^\|]*)", flags=re.MULTILINE)
test_str = "ServiceOperation=Hudson_RetrivePatientNot|Broker_HostName=CHELSEA|RequestDateTime=20190113T03:02:18.209400|MessageTranID=8bfa95c4170911e9b1740a099a2b0000|UserID=A123|AppID=AERO|ExecGrpName=xxxxxx|TimeStamp=2019-01-13T03:02:28.364605|Message=\"RetrievePatientFailure\"|Detail=\"RetreivePatientNotes\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")