package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\bword\b`)
var str = `word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}