package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+([.-]\w+)*@\w+([.-]\w+)*(\.\w{2,8})+$`)
var str = `testing123@testing123.testing123
testing123@testing123.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}