re = /^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$/m
str = 'Mainwatersuply.CralSogenAndSons @domain.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end