using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"facebook.*cpc";
string input = @"free.facebook.com
web.facebook.com
facebook/social/listing
facebook/referral/[facebook][marketplace][house][rent]
facebook/referral/[facebook][marketplace][townhouse][rent]
facebook/cpc/leadgen
facebook/cpc/[facebook][cpc][house][sale]
facebook/cpc/[facebook][cpc][condo][sale]
facebook/cpc/Aus + NZ, Men Over 50s, int Thailand/New Luxury Retirement Village in Southern Thailand
facebook/cpc/[facebook][cpc][townhouse][sale]
facebook/cpc/[facebook][cpc][condo][rent]
facebook/cpc/client->-developer->-leadgen
facebook/cpc/event/
facebook/cpc/[facebook][cpc][land][sale]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}